當前位置: 網站首頁 > 股票軟件公式 > 通達信公式 > 文章 當前位置: 通達信公式 > 文章

通達信雙隧道主圖指標公式

點擊: 次    來源:頂尖財經    作者:股市狙擊 - 小 + 大

買線:=EMA(C,2);
賣線:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(買線,賣線);
SEL:=CROSS(賣線,買線);
STICKLINE(買線>=賣線,LOW,HIGH,0,0),COLORRED;
STICKLINE(買線>=賣線,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(買線<賣線,CLOSE,OPEN,3,0),COLORFFF000;
STICKLINE(買線<賣線,LOW,HIGH,0,0),COLORFFF000;
M60:MA(C,60),COLORGREEN,LINETHICK2;
上揚M60:=M60>=REF(M60,1);
下降M60:=M60<REF(M60,1);
M60上:IF(上揚M60,M60,DRAWNULL),COLORMAGENTA,LINETHICK2;
M20:MA(C,20),COLORGRAY,LINETHICK2;
上揚M20:=M20>=REF(M20,1);
下降M20:=M20<REF(M20,1);
M20上:IF(上揚M20,M20,DRAWNULL),COLORRED,LINETHICK2;
MA144:EMA(CLOSE,144),LINETHICK1,DOTLINE,COLORBLUE,LINETHICK1;
MA169:EMA(CLOSE,169),LINETHICK1,DOTLINE,COLORGREEN,LINETHICK1;
DRAWTEXT_FIX(1,0,0.00,0,'地區: '),COLORYELLOW;DRAWTEXT_FIX(1,0.03,0.00,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.00,0,'行業: '),COLORYELLOW;DRAWTEXT_FIX(1,0.13,0.00,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.00,0,'概念: '),COLORYELLOW;DRAWTEXT_FIX(1,0.23,0.00,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.07,0,'主營同比:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.07,0,CONST(FINANCE(44))),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.07,0,'毛利率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.07,0,CONST((FINANCE(20)-FINANCE(21))/FINANCE(20))*100),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.07,0,'凈益率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.07,0,CONST(FINANCE(30)/FINANCE(19)*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.07,0,'凈利同比:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.34,0.07,0,CONST(FINANCE(43))),COLORYELLOW;
DRAWTEXT_FIX(1,0.40,0.07,0,'凈利潤:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.44,0.07,0,CONST(FINANCE(30)/10000)),COLORYELLOW;
凈資收益率:=(FINANCE(33)/FINANCE(34)*100);
主營利潤率:=(FINANCE(23)/FINANCE(20)*100);
現金負債比:=(FINANCE(25)/FINANCE(15));
主營業增長率:=FINANCE(44);
凈利潤增長率:=FINANCE(43);
每股收益:=CONST(FINANCE(38));
每股凈資產:=CONST(FINANCE(34));
每股現金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公積金:=CONST(FINANCE(18));
流通市值:=ROUND(FINANCE(40)/100000000);
A股流通:=FINANCE(7)/100000000;
市盈率:=DYNAINFO(39);
內外比:=DYNAINFO(51);
量比:=DYNAINFO(17);
成交方向:=DYNAINFO(40);
主動買單:=ISBUYORDER;
均價:=DYNAINFO(11);
PEG指標:=DYNAINFO(39)/FINANCE(43);
市銷率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
現價:=DYNAINFO(7);
振幅:=DYNAINFO(13)*100;
區間成本:=COSTEX(CLOSE,REF(CLOSE,BARSCOUNT(C)-1));
昨收盤價:=DYNAINFO(3);
今開盤價:=DYNAINFO(4);
ER1:=凈資收益率>3;
ER12:=凈資收益率>0.01 AND 凈資收益率<=3;
ER2:=主營利潤率>2;
ER22:=主營利潤率>0;
ER4:=主營業增長率>1;
ER42:=主營業增長率>0;
ER5:=凈利潤增長率>2;
ER52:=凈利潤增長率>0.2;
SAX1:=每股收益>0.01;
SAX12:= 每股收益>0.001;
SAX2:=每股凈資產>2;
SAX22:=每股凈資產>0.01;
SAX4:=每股未分配>0.5;
SAX42:=每股未分配>0.001;
SAX5:=每股公積金>0.5;
SAX52:=每股公積金>0.002;
優秀:=ER1 AND ER2 AND ER4 AND ER5 AND SAX1 AND SAX2
AND SAX4 AND SAX5,COLORRED;
較好:=ER12 AND ER22 AND ER42 AND ER52 AND SAX12 AND SAX22
AND SAX42 AND SAX52,COLORMAGENTA;
DRAWTEXT_FIX(優秀 AND 較好=0,0.645,0.01,0,'基本面:優秀!'),COLORRED;
DRAWTEXT_FIX(較好,0.645,0.06,0,'基本面:較好!'),COLORMAGENTA;
DRAWTEXT_FIX(1,0,0.00,0,'地區: '),COLORYELLOW;DRAWTEXT_FIX(1,0.03,0.00,0,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.00,0,'行業: '),COLORYELLOW;DRAWTEXT_FIX(1,0.13,0.00,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.00,0,'概念: '),COLORYELLOW;DRAWTEXT_FIX(1,0.23,0.00,0,GNBLOCK),COLORYELLOW;
DRAWTEXT_FIX(1,0,0.07,0,'主營同比:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.05,0.07,0,CONST(FINANCE(44))),COLORYELLOW;
DRAWTEXT_FIX(1,0.10,0.07,0,'毛利率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.14,0.07,0,CONST((FINANCE(20)-FINANCE(21))/FINANCE(20))*100),COLORYELLOW;
DRAWTEXT_FIX(1,0.20,0.07,0,'凈益率:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.07,0,CONST(FINANCE(30)/FINANCE(19)*100)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.07,0,'凈利同比:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.34,0.07,0,CONST(FINANCE(43))),COLORYELLOW;
DRAWTEXT_FIX(1,0.40,0.07,0,'凈利潤:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.44,0.07,0,CONST(FINANCE(30)/10000)),COLORYELLOW;
主力籌碼估算:=EMA(WINNER(CLOSE)*70,3),NODRAW,LINETHICK0;
散戶籌碼估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3),NODRAW;
散戶套牢比率:=散戶籌碼估算/(主力籌碼估算+散戶籌碼估算)*100,NODRAW;
主力控盤比率:=主力籌碼估算/(主力籌碼估算+散戶籌碼估算)*100,NODRAW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0,0.13,0,'■ 主力籌碼估算:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.11,0.13,0,' %'),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.08,0.13,0,主力籌碼估算),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.20,0.13,0,'■ 主力控盤比率:'),COLORRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.31,0.13,0,' %'),COLORMAGENTA;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.28,0.13,0,主力控盤比率),COLORMAGENTA;
LC:=REF(CLOSE,1);{股民學院 www.mondayfootballnight.com 整理}
WRSI:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
獲利籌碼:=CONST(WINNER(C)*100);
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能飽和:=(IF(SAT>1,1,SAT)*100);
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活躍:=(WRSI-WR10);
活躍度比:=IF(活躍>=0,(活躍+100)/2,100-ABS((活躍-100)/2));
DRAWTEXT_FIX(1,0.0,0.18,0,STRCAT(STRCAT('量能飽和: ',CON2STR(量能飽和,2)),'%')),COLORRED;
DRAWTEXT_FIX(1,0.12,0.18,0,STRCAT(STRCAT('活躍度比: ',CON2STR(活躍度比,2)),'%')),COLORRED;
DRAWTEXT_FIX(1,0.24,0.18,0,STRCAT(STRCAT('獲利籌碼: ',CON2STR(獲利籌碼,2)),'%')),COLORMAGENTA;

上一篇:通達信MACD+KDJ金叉共振指標公式

下一篇:通達信黃金波浪尺主圖指標公式

亚洲免费在线视频播放